Lightroom not syncing changes made on an iPad

On the whole, I'm very impressed with the Lightroom app on the iPad and I've been using it a lot recently to catch up with the backlog of photos that need minor editing (crop, exposure, etc) and sorting into collections. Unfortunately, after working perfectly for a while I had just finished a batch of changes on the iPad when I discovered that the desktop was no longer syncing the changes being made.

Resolving the syncing issue

The first, and easiest step is to determine whether the syncing issue is between Creative Cloud (CC) and the iPad, or CC and the dekstop. Simply visit http://lightroom.adobe.com/ and sign in. If all the collections and changes are showing correctly on the web then the issue is with the desktop sync, and can be quickly and easily resolved using the method below.

Note: this process will NOT cause you to lose the changes that you have made on the iPad, and which are stored in CC.

  1. Close lightroom (and make a backup of your catalog if desired, always a good idea!)
  2. Navigate to the following folder:
    Mac: /Users/$USER/Library/Caches/Adobe/Lightroom/Sync Data/
    Windows: %USERPROFILE%\AppData\Local\Adobe\Lightroom\Caches\Sync Data\ 
  3. Delete "Sync.lrdata" (or rename it to "Sync.lrdata.old")
  4. Restart Lightroom

At this point, the identity plate at the top of Lightroom should show "Syncing <xxx> photos". It won't take long for this to complete (as it's only syncing the metadata, not the previews). When finished you will find that the sync has completed successfully.

You can use this method to force lightroom dekstop to resync with Creative Cloud - useful for any number of syncing issues!

  • Michael Babb

    Wow, thanks so much for the solution! I had read on other blogs that Lightroom was extremely slow to sync. I had about 2,000 pictures that I rated on my tablet that needed to be synced so I assumed it was going to take a long time. I had been waiting on it to finish syncing for two days and finally decided it wasn’t working. Your post resolved my problem in less than 5 minutes…